Problem: Following a successful initial setup and the installation of the work applications (Work Profile Mode (BYOD)) or after moving the device to fully managed mode (Work Managed Device Mode (COBO)), the work apps suddenly disappear, or the device resets itself.
Note! Here you can find out how to configure the SafetyNet settings in the Cortado Administration Portal.
Possible causes
- The device has had an operating system version update which has not been verified by Google. Such devices don’t meet Google’s so-called SafetyNet Test, which Cortado also uses to safeguard devices. Here is a link to find further information about SafetyNet.
- The device is rooted or the Verified Boot fails for other reasons. Verified Boot tests the integrity of the booting processes. If deviations from the standard are found, then it may be no longer possible to integrate the device into an MDM system, as it can’t be guaranteed that the MDM commands will be executed.
Solution
- You can install the SafetyNet Test app. If your devices fail the test, then, at the least, they are affected by this failure to meet the standard. Wait for a few days. From time to time, OEMs issue operating system updates without informing Google. Usually, they will receive verification later. If you have any doubts, contact your provider/supplier.
- Completely reset the device. Be aware that devices with hardware backup (a hardware feature that prevents the unlocking of the boot loader) can be irreversibly damaged during an attempt to root the device.