Problem: Nach dem erfolgreichen, initialen Setup und der Installation der Arbeitsapplikationen (BYOD) bzw. dem Versetzen des Gerätes in den vollständig verwalteten Modus (COBO), verschwinden plötzlich die Arbeitsapps, bzw. das Gerät setzt sich selbst zurück.
Mögliche Ursachen
Hinweis! Wie Sie die SafetyNet-Einstellungen im Cortado Verwaltungsportal konfigurieren erfahren Sie hier.
1. Das Gerät hat ein Update erhalten/besitzt eine Betriebssystemsversion, welche von Google noch nicht verifiziert worden ist. Diese Geräte bestehen des sog. SafetyNet-Test von Google nicht, welchen Cortado auch verwendet, um Geräte abzusichern. Hier finden Sie weiterführende Informationen zum SafetyNet.
2. Das Gerät ist gerootet oder der Verified Boot schlägt aus anderen Gründen fehl. Verified Boot überprüft die Integrität des Boot-Prozesses. Werden Abweichungen vom Standard gefunden, kann das Gerät ggf. nicht mehr in ein MDM-System eingebunden werden, da nicht sichergestellt werden kann, dass MDM-Befehle ausgeführt werden können.
Lösung
1. Sie können auf den betroffenen Geräten die App SafetyNet Test installieren. Fallen Ihre Geräte durch den Test, sind sie mindestens von diesem Umstand betroffen. Warten Sie einige Tage ab. Es kommt ab und zu vor, dass OEMs Betriebssystemsupdates ausgeben, ohne diese Google zu kommunizieren. Ggf. wird diese Verifizierung später nachgeholt. Wenden Sie sich im Zweifel an Ihren Provider/Zulieferer.
2. Setzen Sie das Gerät komplett zurück. Beachten Sie dabei, dass Geräte mit Hardware-Sicherung (ein Hardware-Feature, welches das Entsperren des Bootloaders verhindert) durch einen Root-Versuch irreversibel beschädigt worden sein können.