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Zugewiesene Android-Apps werden nicht automatisch installiert

Problem: Nach dem Zuweisen einer Android-App wird die gewünschte App nicht auf den Geräten installiert. Unter Devices→ MDM States oder Devices→ Apps&Docs findet sich der Vermerk Pending.

Mögliche Ursachen

1. Fehlender Rollout der Group Templates

2. Änderungen der App-Berechtigungen wurden nicht akzeptiert

3. Die Endgeräte sind nicht für Google bzw. für Cortado erreichbar

4. Die Stromspar-/Leistungseinstellungen der Hersteller unterbinden die Installation einer App

Lösung

1. Wenn Sie die App einer Nutzergruppe zugewiesen haben, müssen Sie die Änderung am Gruppentemplate zuerst ausrollen. Wechseln Sie dazu auf Control Panel→ Group Templates→ Apps&Docs und wählen dort die App aus, die Sie neu hinzugefügt haben. Klicken Sie anschließend auf der rechten Seite auf Rollout. Weitere Informationen dazu finden Sie im Handbuch für Cortado MDM bzw. für Cortado Server.

2. Wenn Applikationen ein Update erhalten, dann müssen ggf. neue Berechtigungen oder Einstellungsmöglichkeiten der Apps akzeptiert bzw. synchronisiert werden. Wechseln Sie hierzu auf Control Panel→ Apps &Docs→ VPP Accounts und wählen Sie Ihren Android VPP Account aus. Klicken Sie auf der rechten Seite auf Refresh.

Überprüfen Sie Ihre Apps (linke Spalte) auf roten Ausrufezeichen. Wählen Sie solche Applikationen aus und akzeptieren Sie unter Details die neuen Berechtigungen/Einstellungsmöglichkeiten.

3. Cortado sendet über die Infrastruktur von Google, Weckbefehle an Endgeräte, die sich darauf hin bei Cortado zurückmelden und App-Installationsbefehle erhalten. Sind die Endgeräte in einem Netzwerk, welches die Kommunikation mit Google oder Cortado unterbindet, können die Geräte keine Befehle empfangen. Wechseln Sie im Zweifel das Netzwerk.

4. Beobachten Sie auf einem Testtelefon, welches mit einem WLAN verbunden ist, das keinen besonderen Einschränkungen unterliegt und mit einem Ladekabel mit Strom versorgt wird, ob die App nun ausgeliefert wird. Wenn die App innerhalb von 10 Minuten nicht installiert werden sollte, öffnen Sie bitte den (geschäftlichen) PlayStore auf dem mobilen Gerät und überprüfen Sie, ob Sie die Apps im Menü unter Meine Apps für die Arbeit finden. Sind die Apps dort hinterlegt, hat die Zuweisung schon stattgefunden, das Gerät hat allerdings eine automatische Installation abgelehnt. Kommt dieses Verhalten trotz Verbindung zu WLAN und Stromquelle häufiger vor, sollten Sie sich an den Hersteller der Geräte wenden, oder überprüfen, ob sehr aufwendige Applikationen auf den Geräten ausgeführt werden.

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